RPCS3 no controller connected

Discussion in 'General Discussion' started by nethunter, Jun 9, 2019.

  1. nethunter

    nethunter New Member

    Hi, I am trying to install RPCS3 and add a game. I can't connect my PS3 style PC controller. It works with my other Emulators ( RetroArch, NES and SNES etc...) I am attaching screenshots. I tried Scp Toolkit. For Dualshock 3, Xinput and MMyJoyPad. The Keyboard shows mapping the controller is fine. Xinput and MMJoaypad are fine. (I can edit the buttons.) Default buttons look fine. The DualShock 3 is greyed out. It shows disconnected. Xinput and Joypad show connected. When I start Black Ops 3 the controller doesn't work. It goes to the first page and says to click "X". I tried all buttons it doesn't take me to the next COD page. I noticed SCP had errors. One said "Fake PS3 Controller." In Scp, I unchecked "Install Bluetooth Driver", "Install Dualshock 4 driver" and kept "Install Dualshock 3." Like I said my PS3/PC controller works fine on other emulators. Please reply. Thanks

    https://drive.google.com/open?id=1PF4b327LJjjLgIInoRKe0IWMI9ct1_b3
     
  2. nethunter

    nethunter New Member

    Hi, I'm back. Now my Controller doesn't work with RetroArch (SNES-9x). I tried the button settings but when I press the buttons nothing happens. (If I hit enter for the direction up it gives me a few seconds to hit "up" but when I do nothing happens.) I can't map the controller. RetroArch can't see it. Any ideas? I'll check back.
     
  3. nethunter

    nethunter New Member

    I got my Controller working on RetroArch. I used Scp Toolkit and uninstalled the PS3 controller. Now it works with RetroArch. RPCS3 still doesn't work. Is PS3 on RetroArch? What core?
     
  4. Prectorian

    Prectorian . Staff Member

    I don't have a PS3 controller, so I can't be of much assistance. RPCS3 as mentioned by the dev team hasn't natively support it, but recommend using RetroArch as possible workaround. Therefore I'd suggest you check the RetroArch's website for answers, though I think it should be possible to use on RPCS3 with the latest version.
     
  5. nethunter

    nethunter New Member

    Hi, I will try the RetroArch website for my Controller. I have RPCS3 at version 4.84. Hopefully, RetroArch will solve this. Thanks!
     
  6. morningstar24

    morningstar24 Member

    The RetroArch one works great for me
    It only took me 2 weekends to transition from Hyperspin / RocketLauncher / full emulators to Launchbox / Retroarch and it resulted in a more airy, simpler and more portable system.
     

Share This Page